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Chapter 1 Introduction to Bio-SPICE 
 

With the enormous growth of life science research it is clear that tools are 
needed to store and analyze the large amount of experimental data, to 
build, simulate and analyze mathematical models, and to visualize data 
and system dynamics.  
This chapter presents the software project Bio-SPICE (Biological  
Simulation Program for Intra- and Inter-Cell Evaluation) and a short 
description of system biology. 
 

Introduction to systems biology 

Systems biology is the study of the mechanisms underlying complex 
biological processes as integrated systems of many, diverse, interacting 
components. Systems biology involves (1) collection of large sets of 
experimental data (by high-throughput technologies and/or by mining the 
literature of reductionist molecular biology and biochemistry), (2) proposal of 
mathematical models that might account for at least some significant aspects 
of this data set, (3) accurate computer solution of the mathematical equations 
to obtain numerical predictions, and (4) assessment of the quality of the 
model by comparing numerical simulations with the experimental data. 
(http://jigcell.biol.vt.edu/glossary.html) 

 

Modeling biochemical and gene networks 

There are several methods of modeling system biology, in particular cellular 
processes and biochemical interactions. Two very different approaches are 
Boolean networks and ordinary differential equations (ODEs). For qualitative 
modeling of large systems, Boolean networks may be more appropriate than 
an ODE-based model where details of reaction rates are required.  

Boolean methods 
Qualitative modeling of large systems can most effectively be carried out 
using a Boolean method. There are several variants of Boolean methods, 
e.g., PetriNets and Cellular Automata. A Boolean network contains nodes that 
can have the value 1 (on) or 0 (off). For a specific node, the change from one 
state to the next is a function of the nodes that are connected to the specified 
node. 

Differential equation-based models 
Quantitative modeling is usually carried out with ordinary differential 
equations, which represent system variables that change as nonlinear 
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functions of other variables and/or parameters. To describe mass action of 
biochemical reactions, equations may be written in stochiometric form. There 
are two general types of solvers for quantitative models, stochastic and 
deterministic. When small populations of molecules are considered, 
stochastic modeling is more appropriate since molecular fluctuations may 
alter the dynamics. With large population sizes, deterministic modeling will be 
computationally faster as stochastic modeling of large populations is 
computationally time intensive and should produce results similar to an ODE 
model. 

Stochastic 
Stochastic solvers use the Gillespie algorithm or a variant of it. Basically, all 
possible reactions are examined and the reaction with the shortest time 
interval is “scheduled”. The executed reaction will affect the population of 
molecules and thereby other reactions. Therefore certain reaction times must 
be recalculated, and again, the shortest time interval reaction is scheduled. 
This algorithm was shown to describe the time evolution of a chemical 
system. 

Deterministic 
Deterministic solvers use a variety of algorithms to compute the value of the 
variables in a model. At each time step, all variables are calculated based on 
either only previous values (explicit methods) or incorporating estimates of 
the next value (implicit methods). Some of the more known algorithms are 
forward and backward Euler method (explicit and implicit respectively), Runge 
Kutta, Gear, CVODE, Crank-Nicolson. The algorithms differ in terms of ease 
of use (e.g., explicit methods requiring only initial conditions, implicit methods 
require estimations of variable values), speed of computation (how many 
function calls per time step) and accuracy especially important in cases of stiff 
systems. 

The Bio-SPICE project 

The Bio-SPICE project was started as part of the Bio-Computation program, 
funded by the Defense Advanced Research Projects Agency (DARPA). The 
goal was to develop a computational framework that enables the construction 
of sophisticated models of intracellular processes that can be used to predict 
and control the behavior of living cells. In addition, Bio-SPICE is also being 
examined to generate new computational paradigms and engineering 
applications that utilize biomolecules as an information processing, sensing, 
or structural components 
(http://www.darpa.mil/ipto/programs/biocomp/index.htm). In order to 
understand cellular behavior, we need to understand how the underlying 
genetic code is executed and to characterize the dynamics of cellular events 
(see editorial at http://www.liebertonline.com/toc/omi/7/3).  
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The Bio-SPICE project chose the System Biology Markup Language (SBML) 
as a language of exchange between the different tools. SBML is a computer-
readable format for representing models of biochemical reaction networks. 
For example, SBML is applicable to metabolic networks, cell-signaling 
pathways and regulatory networks. For further details see the web site 
http://sbml.org/index.psp. 

The Bio-SPICE web site and SourceForge.net 

The Bio-SPICE web site https://biospice.org/index.php provides information 
and software downloads to the Bio-SPICE community. 
 

 
 
Figure 1.1 Bio-SPICE web site. 
 

 
 

 
In order to download software from the web site, you must join and become a 
Bio-SPICE member. Chapter 2, Getting Started describes how to go about 
joining. 
 
A second source now exists for the Bio-SPICE project is on SourceForge.net,  
http://sourceforge.net/projects/biospice. The latest version of the Dashboard 
can be downloaded from SourceForge.net without the need to register as a 
Bio-SPICE user as on the official Bio-SPICE web site. This reflects the 
transition from a DARPA funded program to a truly open source environment 
to fulfill the desire to see Bio-SPICE continue to mature and evolve long after 
the DARPA funding has ended. 

The Bio-SPICE tool kit 

The Bio-SPICE tool kit is comprised of the Dashboard and a range of tools.  
• Dashboard:  GUI application to create and run workflows. 
• Data analysis tools: Tools to mine the data 
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• Database tools: The large amount of data that experiments produce needs 
to be stored and mined. 

• Model analysis tools:  A model can provide information through various 
means of analysis, e.g., bifurcation, parameter sensitivity. 

• Model composition & visualization tools: In order to construct a model, 
tools are provided for model composition, as well as visualization. 

• Simulator tools:  Models need to be solved using various types of 
simulators, continuous ODE simulators or stochastic simulators. 

 
 

Outline 

The manual is organized as follows: 
• Introduction – This chapter provides a general overview of System 

Biology and the Bio-SPICE software. 
• Getting Started – Chapter 2 describes how to download the Bio-SPICE 

package and launch the application. 
• Model Editor – Chapter 3 presents an simple use case and describes 

how to edit a model. 
• Using the Dashboard – Chapter 4 shows how to use the Dashboard to 

simulate the model described in Chapter 3. 
• Using Bio-SPICE Tools – Chapter 5 provides a brief summary of all the 

Bio-SPICE tools available. 
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Chapter 2 Getting Started 
 
This chapter presents the Dashboard application, and shows how to 
download and install the Dashboard. 

The Dashboard 

The Bio-SPICE Dashboard is an environment for integrating varied data and 
tools useful to biologists. The main categories of tools this environment was 
designed for are model building, model analysis, experimental data analysis, 
and visualization. However, conceivably any tool that analyzes, transforms, 
produces, or helps to interpret data could be integrated into the Dashboard. 
The Dashboard functions in a manner loosely analogous to UNIX shells 
(especially with respect to UNIX pipe facilities). 
 
The Dashboard is based on the NetBeans application platform, a Java-based 
tool kit. Tools may be written in any language, however, as the core 
Dashboard libraries provide support for accessing non-Java tools that are 
either network enabled, command-line tools, or OAA agents. 
 
Currently, facilities for Java and OAA tools are available, as well as support 
for TCP/IP, web, and command-line tools via an XML wrapping API. 
 
Users or tool developers interested in integrating their tools into the 
Dashboard environment can find additional guidance in the Developer’s 
Manual. 
 

System Requirements 

Java SDK version 1.4.5.  Download from http://java.sun.com. 
Linux users:  It may be necessary to have super-user permission (i.e., root) 
before you install the software.  Check with your local system administrator. 

Bio-SPICE on SourceForge.net 

The Bio-SPICE software may be downloaded from the SourceForge.net site 
at http://sourceforge.net/projects/biospice/.  
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Figure 2.1 SourceForge Dashboard page 
 
 
Click on the green button Download Bio-SPICE, see Fig. 2.1, and you will be 
directed to the download page. There are three versions of the software for 
the operating systems:  Windows (32bit), Linux (32bit) and Mac (PPC), shown 
in Fig. 2.2. 
 

 
Figure 2.2 SourceForge Dashboard download page 
 

Installing the Dashboard from SourceForge 

 
There are three versions of the dashboard, for Windows, Linux and Macintosh 
operating systems. Select the version you need. Then save either the Windows 
file Dashboard-SetupWindows-7.0.exe or the Linux file Dashboard-
SetupLinux-7.0.bin or the Machintosh file Dashboard-mac-7.0.zip on your 
computer. 
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The installer will have an icon which looks like this,  for MS Windows, 
double-click on the icon to launch the installer, see Fig. 2.3.  

 

 
 
Figure 2.3 Dashboard InstallShield Wizard. 

 
 
 

 

Note: In order for the Dashboard to function you must have a Java VM installed, of a 
version 1.4 or later. If you do not have Java installed or, have an older version, visit 

the Java site http://java.sun.com in order to download the appropriate Java VM. 

 
The installer will provide a default folder/directory for installations, but you 
may change the destination folder/directory. Click the button  to open 
a dialog box displaying the file structure for your system. Traverse the 
structure to the folder in which you want to install Bio-SPICE. Select the folder 
name and click the button open and then next. The installer will then display 
the installation files. Leave the two check marks for installation of both the 
Dashboard and OAA for a complete install. Click the button next twice to start 
the installation. After installation click the buttons next and then finish. 
 
The installation will place four folders, _jvm, _uninstall, Dashboard, and 
OAA in the designated folder, and place three shortcuts, to the Dashboard, to 
uninstall the Dashboard, and to the OAA Facilitator, on the Desktop.  
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To launch the Dashboard, double-click on the Dashboard shortcut. 

 
In the next chapter we will show how to use the Dashboard to construct a 
biochemical model. 
 
The Bio-SPICE documentation, shown in Fig. 2.4, has been integrated into 
the Dashboard. Click on the menu item Help>Help Contents in order to 
open the documentation window. 
 

 

 
 
Figure 2.4 Access the Dashboard manual from Bio-SPICE web site. 
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Chapter 3 Model Editor 
 

This chapter presents how to implement a model with Bio-SPICE. We will use 
the model editor BioSpreadsheet to construct a biochemical model. 

Choosing an editor 

There are several model editors available in Bio-SPICE. Each simulator 
provides an accompanying editor, which is best suited for use with the 
specific simulator. On the other hand, each editor provides an export function 
that allows you to save the model in SBML format. SBML is the language of 
exchange for models and each simulator provides you with an import function 
to read SBML models.  
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Note: At present there is not full interoperability between all editors and 
simulators. The import function of one tool may not read correctly the 
entire SBML model from another tool. See Appendix 2 for a table of 
interoperability of Bio-SPICE tools. 
 

imulator contributions to earlier versions of Bio-SPICE all included editors 
or model construction, due to the fact that no standard data format was 
stablished. As the need for interoperability expanded, SBML was chosen as 
 language of exchange for the various tools. All editors provide an SBML 
port/export function.  One of the original contributors to Bio-SPICE was a 

eam from the University of Tennessee at Knoxville (UTK) and Oak Ridge 
ational Lab (ORNL) which provided the editor BioSpreadsheet with the 
ccompanying stochastic solver ESS. 

nloading an editor 

ith the move of Bio-SPICE to SourceForge.net, it is best to download Bio-
PICE tools from the web site of the contributing group, if such a site exists. 
 few of the contributing teams have been found to do a better job making 

ecent tools releases and fixes available to others on their own web site than 
n the Bio-SPICE web site. Some tools though are only provided on the Bio-
PICE web site https://biospice.org/ . Appendix I provides the list of tools from 

he various organizations and the web site most convenient to access them. 

he tools from the University of Tennessee at Knoxville (UTK) and Oak Ridge 
ational Lab (ORNL) can be found at: http://biocomp.ece.utk.edu/, see Fig. 
.1. 
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         Figure 3.1 University of Tennessee Biological Modeling Research Group webpage. 
 
 
 
 
The editor BioSpreadsheet is a simple-to-use editor for developing models of 
mass action equations. It was developed in conjunction to the stochastic 
solver ESS (Exact Stochastic Simulator) as part of the software contribution 
of UTK/ORNL. 
 
Click the Software link to open the download page 
http://biocomp.ece.utk.edu/tools.html. Click the link Download Now and save 
the file utkornltools.zip to disk. 
Unzip the file utkornltools.zip to install the folder utkornltools, which 
contains the following structure: 
 

 
 
The unzipped utkornltools folder will look something like this: 
 

 
Figure 3.2 Folder utkornltools. 
 
The PDF file README, on page 3, describes how to install the UTK-ORNL tools 
in the Bio-SPICE Dashboard. Briefly, the file utkornltools.nbm must be 
installed by using Install Manually Downloaded Modules from the menu 
Tools>Update Center. Manual install is used when the tool file resides on 
your hard drive. Automatic install is used to download the tool file from the 
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update center. Relaunch the Dashboard to have access to the UTK-ORNL 
tools. The Dashboard should look as in Fig. 3.3. 
 

 
 

              Figure 3.3 Dashboard with UTK-ORNL tools installed. 
 
To launch the BioSpreadsheet editor, you must first place the BioSpreadsheet 
analyzer on a workflow. Double-click the BioSpreadsheet analyzer on the left 
pane of the Dashboard and drag the cursor, while holding the left mouse 
button, to the workflow area on the right pane of the Dashboard.  
 

 
 

        Figure 3.4 BioSpreadsheet analyzer in workflow editor. 
 
Click the menu Run>Start in order to start BioSpreadsheet which should 
open a window as in Fig. 3.5. 
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Using an editor 

The BioSpreadsheet editor has four panes, each associated with a tab 
Information, Reactions, Species and Parameters, and its corresponding 
panel. 
 

 
 

                Figure 3.5 BioSpreadsheet application window. 
 
A model in BioSpreadsheet is composed of the model name, the species or 
variables, the list of reactions and possible parameters. By selecting the 
desired tag, the appropriate pane will be displayed. 
 
 

Implementation of a model 

 
In order to demonstrate the BioSpreadsheet editor, a circadian rhythm model 
will be implemented. This model corresponds to the oscillations in the levels 
of core gene expression due to negative feedback.  The model uses a 
transcription factor (TF) which undergoes multiple phosphorylation steps. 
Over the space of a day, TF proteins becomes fully phosphorylated and 
relieve TF repression so that another "burst" of TF transcription can occur, 
see Fig. 3.6. 
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Figure 3.6 Diagram of Circadian model. 
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Figure 3.7 Circadian ODE model. Parameters: Vr=7.0, Kr=0.0005, kd=0.2, kp=0.2,kph=2.0,Vp=3.0,Kp=0.0001. 
 
 

 
               

 Figure 3.8 Circadian model oscillations of mRNA (red), P0 (green) and P12 (blue). 
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Since the BioSpreadsheet  editor only accepts models in the form of mass 
action equations, the ODE model of Fig. 3.7 must be converted to mass 
action form.  
 
Converting a linear ODE is simple since every term represents a mass action 
reaction. For example, the equation above 
 

]0[TFphk[mRNA]pk
dt

]0d[TF
−=  

represents a linear production term and a linear degradation term. Two mass 
action equations are needed, one for each term. Of course for mass balance, 
the degradation term for P0 is equivalent to the production term for P1. 
 

1TF0TF
phk

→  

 
The nonlinear terms, such as those using the Michaelis-Menten formalism are 
more difficult to convert into mass action form. Since the Michaelis-Menten 
formalism takes advantage of the quasi-steady-state approximation, this 
assumption which reduces the complexity of the model is not valid for a 
system of mass action equations, and must be expanded to its original form. 
 
 
In order to unpack the equations, new variables are needed. There are two 
ODEs of the circadian model with Michaelis-Menten terms, the equations for 
mRNA and TF12. In the case of the ODE for mRNA, the Michaelis-Menten 
term contributes to the production of mRNA. While in the ODE for TF12, the 
Michaelis-Menten term is part of the removal of TF12. It is not our intent in 
this manual to deal with the subject of converting nonlinear ODEs to mass 
action equations. Figure 3.9 provides the equations for the model of Fig. 3.7 
in mass action format. Figure 3.10 illustrates the response of the mass action 
equation model which is similar to the time course of the original model, 
shown in Fig. 3.8. 
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Figure 3.9 Circadian model in mass action form. Rate values are: 18.2, 65.0, 130.0, 0.26, 0.26, 2.6 (i=0 to 11), 3.9, 39.0, 3.9. 
 

 
Figure 3.10 Circadian oscillations of mass action model. 

 

Entering Model in BioSpreadsheet 

The BioSpreadsheet editor provides a Species panel for declaring the model 
species and a Reactions panel that is used for entering model equations.  
Click the Species tab to open the Species panel. Click the button Add, to 
insert a blank line, as shown in Figure 3.11. 
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            Figure 3.11 BioSpreadsheet Reaction panel. 
 
 
 
Each term of the mass action equations is a species that needs to be defined 
in the BioSpreadsheet Species panel. Only three species have initial values 
different from zero. The initial value of mRNA is 3, promoter is 2, and x is 10. 
Figure 3.12 presents the complete species panel for the circadian model. 
 

 
 

Figure 3.12 Species panel of BioSpreadsheet editor. 
 
 

 
 
The next step is to define the reactions of the model. Select the Reactions tab 
in the BioSpreadsheet editor. Use the button Add to insert a blank line in the 
panel.  Select the column you want to write in. There are 20 mass action 
equations in the Circadian model. The final model should look like Figure 
3.12. 
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Figure 3.13 Mass action equations for the circadian model. 
 

 
 
The last panel we need to modify is the panel Parameters. Since all the 
phosphorylation steps use the same rate constant, we can define the value as 
a parameter. Open the Parameter panel by selecting the Parameter tab. Click 
the button Add to insert a new blank line. Click the column with the mouse 
and enter the parameter rateP, click the Tab key and enter the value 2.6. 
 
In order to use the model file within the Dashboard, it must be saved in SBML 
format. BioSpreadsheet provides an export function, in the File menu, in order 
to save the model in SBML format. Click File>Export SBML to open a 
Save dialog box. For our example, we have chosen the filename 
circadianModel.sbml. 
 
To edit a SBML file, use the input SBML command to open the file in 
BioSpreadsheet. Click File>Import SBML to open a dialog box to select 
the desired SBML file. 
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Chapter 4   Using the Dashboard 
 

This chapter presents the Dashboard application, which is the environment 
for invoking Bio-SPICE tools. The tools provided by the Dashboard are 
referred to as analyzers, and any tool that is installed is represented by an 
icon in the analyzer pane. You will learn how to construct a workflow and run 
a simulation, as well as how to visualize the results. 

Dashboard description 

The Bio-SPICE Dashboard is an environment for integrating varied data and 
tools useful to biologists. The main categories of tools this environment was 
designed for are model building, model analysis, experimental data analysis, 
and visualization. However, conceivably any tool that analyzes, transforms, 
produces, or helps to interpret data could be integrated into the Dashboard. 
The Dashboard functions in a manner loosely analogous to UNIX shells 
(especially with respect to UNIX pipe facilities). 
 
The Dashboard is based on the NetBeans application platform, a Java-based 
tool kit. Tools may be written in any language, however, as the core 
Dashboard libraries provide support for accessing non-Java tools that are 
network enabled, command-line tools, or OAA agents. 
 
Currently, facilities for Java and OAA tools are available, as well as support 
for TCP/IP, web, and command-line tools via an XML wrapping API. 

 
The Dashboard consists of two panes, a left pane for viewing analyzers and 
the file system, and a right pane for the workflow editor and output 
visualization. The Dashboard provides a library of tools that you can connect 
and configure for your needs. By default, the Dashboard contains several 
basic analyzers, e.g., a table viewer and a data plotter. 

 

Dashboard workflow 

The Dashboard provides an environment where you can connect data files 
and the various tools of Bio-SPICE. In order to connect the varied data and 
tools, the Dashboard provides a workflow editor. The workflow editor allows 
you to define source documents e.g., a SBML model file, and direct the 
document to a tool, e.g., an editor or a simulator. The tools can produce 
output data which you can visualize with a graphing tool. 
 
A workflow is an acyclic graph representing a high-level task that a user 
wishes to run. The individual parts of this task are all the nodes in a workflow, 
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and consist of all the modules that will be run and the data they will be 
analyzing or producing. A workflow may contain source documents, 
destination documents, and analyzers. A source document represents data 
read from a file. Similarly, a destination document represents data being 
written to a file. Analyzers may have any number of inputs and/or outputs. For 
a workflow to be valid, all required inputs and outputs from all nodes 
(documents and analyzers) must be satisfied. In addition, all source and 
destination documents must have a file associated with them. Analyzer inputs 
and outputs may be satisfied by connecting links to other documents and 
analyzers of matching type. In addition, some analyzer inputs (for example, 
text) may be satisified by manually editing the input parameters. 
 
In order to run the model we have developed with BioSpreadsheet, the 
stochastic solver ESS needs to be downloaded.  
 

Running the Dashboard 

Windows users should find shortcut links on their desktop to the Dashboard, 
the OAA factilitator, and the Dashboard Uninstaller. Double-click on the 

Dashboard shortcut icon  to launch the application.  
To launch the application directly, locate the Dashboard's bin directory. 

• On Windows, this is most likely: C:\Program Files\Bio-
SPICE\Dashboard[Version #]\Dashboard\bin 

• On Linux, this is most likely: /opt/Bio-
SPICE/Dashboard2.0.0/Dashboard/bin 

The executable to run the Dashboard is named "runide" 

• Windows users: double-click on runidew.exe. There is also runide.exe, 
which starts a console window in addition to the Dashboard. Debugging 
and/or information messages are sometimes printed to this console 
window. 

• Linux users: run ./runide.sh 

 
By default the Dashboard opens the workflow editor on the right pane, as 
seen in Figure 4.1. If you find the editor window has closed, you may open 
the workflow editor by clicking Bio-SPICE>Open Workflow Editor. You 
may open several workflow windows and use the workflow editor tab to select 
the desired workflow. 
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Figure 4.1 Default Dashboard with basic set of Analyzers. 
 
 

Installing UTK-ORNL tools 

In the previous chapter we briefly described how to install the tools from UTK-
ORNL in the Bio-SPICE Dashboard. The UTK-ORNL documentation 
describes the procedure on page 3 of the README document. 
Briefly, the file utkornltools.nbm must be installed by using Install 
Manually Downloaded Modules from the menu Tools>Update Center. 
After relaunching the Dashboard, the UTK-ORNL tools will appear in the 
analyzer pane on the left. 
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4.2 Dashboard with UTK-ORNL tools installed. 

Opening a source file 

The first step in creating a simulation workflow is to provide input data for the 
simulation. This is called a source document. Click the menu 
Add>Document>Source as shown in Figure 4.3.  
 

 
 

      Figure 4.3 Add a source document to the Workflow editor. 
 
The source document icon will appear in the workflow editor pane (see Fig. 
4.4). Click the document icon and right-click to open the pull-down menu. 
Click the item edit, as shown in Fig. 4.4. A dialog box will open which allows 
you to locate the file to load as the source document. 
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 Figure 4.4 Edit the source document to select the input file. 
 
Select the source file circadianModel.sbml and the file name will appear 
above the source document icon, as shown in Fig. 4.5. 

Building a workflow 

 
Constructing a workflow entails connecting the building blocks from an initial 
source document to a final output document or plot.  There are two ways to 
add a component box to the workflow. Using the button Add, you may 
incorporate a source document or an analyzer. As well, the analyzers 
presented in the component pane can be selected and dragged onto the 
workflow pane. In order to connect two components, select the right side of 
the leading component and extend the black line to the left side of the second 
component. The Dashboard will allow you to connect two components that 
are designed to be joined in a workflow, otherwise, attempting to connect two 
components that are not designed to be connected will fail.  
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Figure 4.5 Insert a BioSpreadsheet analyzer in the workflow. 
 
 

The source document is attached to the analyzer by connecting the output 
socket (rightward protruding arrow head) to the input socket (leftward 
protruding arrow tail) of the analyzer. Right-click the arrow heard and hold the 
button as you draw a line to the arrow tail, as seen in Figure 4.6. Once the 
connection is established the line will remain when you release the button. 
Double-click the analyzer to open the analyzer parameter box to confirm the 
input source document format. When this is done, the red line on the bottom 
of the source document icon will turn to green, meaning the connection is 
established and verified, as seen in Fig. 4.7. 

 
 
 

 
 

Figure 4.6 Connect source document to analyzer in workflow. 
 

 
The output from the ESS analyzer may be directed into the 2D Grapher 
analyzer which is provided with the Dashboard.  
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There are several ways of adding analyzers to the workflow. You may also 
select an analyzer from the analyzer pane. Click the analyzer 2D Grapher 
and right-click to open a menu, select Add To Workflow, as seen in Fig. 4.7. 
 

 
 

Figure 4.7 Add ESS analyzer from analyzer pane. 
 
 
Figure 4.8 shows the complete workflow. Click the ESS analyzer to open a 
dialog window to set simulation parameters. Figure 4.9 shows the three 
parameters that you must provide, the print interval, end time and seed 
number, the values 1, 100 and 1 were used respectively, within quotes (“ ”) 
due to the required string format. 
 

 
 

       Figure 4.8 Connect ESS analyzer to 2D Grapher analyzer in workflow. 
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        Figure 4.9 ESS analyzer requires three parameters for simulation. 
 
 

Save the workflow by clicking the menu Workflow>Save and typing the 
filename in the desired folder. For this tutorial, we have chosen 
Tutorial_CircModelSim.wf in folder tutorialExamples.  

Running a simulation 

With a complete workflow, it is possible to run a simulation and examine the 
time course of the model variables.  
 
 

 
 
              Figure 4.10 Launching a simulation. 

 
 

To launch a simulation click the menu Run>Start. The Dashboard displays 
the progression of the simulation by highlighting the analyzer of the workflow 
that is active with a green square. 
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When the simulation ends, 2D Grapher will display the time course of the 
model variables, as seen in Fig. 4.11. 
 
 
 

 
 

Figure 4.11 Plot of circadian model time course. 
 
 
The results displayed with 2D Grapher show the time course of all the 
variable of our model. Normally we want to limit the display to certain 
specified variables.  
 
The 2D Grapher analyzer allows you to edit the variables to be displayed. To 
select the variable you wish to display click the button Edit Graph 
Parameters. A window will open, as seen in Figure 4.12. Click the variables 
you wish to display, using the Shift key to select blocks of variables and the 
Control (Ctrl) key to select multiple individual variables. 
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               Figure 4.12 Using the 2D Grapher property option you may select specific variable to display. 
 
Click the button Apply in the Graph Properties dialog box in order to update 
the display, as seen in Fig. 4.13. 

 
 
 

 
 

 Figure 4.13 Workflow with 2D Grapher analyzer. 
 
 

Updating a file 

 
So far we have seen how to run a simulation using the Dashboard. After 
running a simulation we would like to examine the behavior of the model 
using different parameter values. In order to modify the parameter values we 
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need to create a workflow consisting of a source document connected to the 
BioSpreadsheet analyzer. Click the edit menu of the source document, as 
shown in Fig. 4.4, to load the file you wish to edit. Figure 4.14 presents such a 
workflow with the source document circadianModel.sbml that was 
described in chapter 3. Click the menu item Run>Start to execute the 
workflow and open the BioSpreadsheet editor with the desired file. Change 
the parameter value and save the file by clicking File>Export SBML. In our 
case, export the model using the same filename as before. Run the workflow 
with the updated parameters to view the change in system behavior. If you 
provide a new filename, the new filename will have to be provided as the 
source document, which you may change my right-clicking the icon and 
clicking the item edit.  

 
 

 
 

     Figure 4.14 A workflow to open BioSpreadsheet editor to update file. 
 

Installing Additional Tools in the Dashboard 

 
In the previous section, we saw how to construct a workflow and run a 
simulation.  
 
There are several ways of installing tools in the Dashboard. The Dashboard 
provides a way to connect to an update center from which you may select and 
download tools. 
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Figure 4.15 The Bio-SPICE update center wizard. 
 
 
Click the menu item Tools>Update Center to open the Update Center 
wizard, seen in Figure 4.15. Click the button Next to view the possible 
updates available. The wizard will connect to the Bio-SPICE web site and 
download the list of available components.  
 
Scroll down the list of possible downloads and click the tool you need. Click 
the right arrow to move the module to the right pane titled include in 
install, as seen in Figure 4.16. 
 
 

 
 
Figure 4.16 Update center wizard with list of available downloads. 
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Click the button Next to download the program, you will be asked to accept 
the License Agreement. Click the button Finish in order to install the tool. 
 
If the tool is properly installed, you will see the icon in the analyzer pane, after 
restarting the Dashboard. 
 

 
 

Importing an Analyzer 

Tool analyzers may be defined by an xml file which can be installed in the 
Dashboard by using the import Analyzer command. Click the pull-down menu 
item Bio-SPICE>import Analyzer to open a dialog box which displays the 
file hierarchy. Traverse the file structure in order to reach the folder/directory 
of interest. Click the file toolName.xml and click the button open. After 
importing the analyzer, the Dashboard needs to be restarted to show the 
analyzer icon. 
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Chapter  5 Using Bio-SPICE Tools 
 

The Bio-SPICE toolkit consists of the Dashboard application and numerous 
types of tools. Users are provided with model editor tools, simulators, 
database tools as well as visualization tools. 
 
The Bio-SPICE web site, https://biospice.org/index.php provides the tools that 
may be incorporated into the Dashboard. The listing of the tools may be 
viewed in several ways, by alphabetical order, by order of organization that 
developed the tool, or by order of functional category. 
 

 
 

             Figure 5.1 Bio-SPICE tools listings by organization. 
 

The tool page provides a description for each tool which can be accessed by 
clicking the link in red View_detail after each tool name. 
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Appendix 1: Bio-SPICE Components List 
 
 
 
Organization Tools Web Site 
CalTech – California 
Institute of Technology 

SOSTools https://biospice.org 

Columbia GeneWays http://geneways.genome
center.columbia.edu/ 

Harvard BioWarehouse2SBML, Fluxor http://arep.med.harvard.
edu/moma/ 

KGI –  Keck Graduate 
Institute 

JDesigner, Jarnac, MetaTool, 
 Optimizer, SBWMatlab 

http://sys-bio.org 

LBL –  Laurence Berkeley 
Lab 

HomologFinder, 
SensitivityAnalyzer,  
Pathway Builder 

http://biospice.lbl.gov/P
athwayBuilder/ 

NYU –  
New York University 

NYUMAD,  
MYUSIM, Simpathica 

http://bioinformatics.nyu
.edu/Projects/Simpathica 

MolSci – The molecular 
science institute 

MONOD http://monod.molsci.org/ 

SRI – Stanford Research 
Institute 

BioWarehouse, BioMatBridge, 
SAL, Hybrid Automata, 
Symbolic Reachability Tool 

http://bioinformatics.ai.s
ri.com/ 

TJU – Thomas Jefferson 
University 

CloneUpdater,  
MetaCluster, PAINT 

http://www.dbi.tju.edu/d
bi/tools/paint/ 

Indiana University CellX, Karyote Cell Analyzer, 
Karyote Genome Analyzer 

https://systemsbiology.in
diana.edu/cellx/ 

UCLA – University of 
California at Los Angeles 

GeneScreen, IcDNA,  
MIAME Spice, NCA 

http://www.ee.ucla.edu/
~riccardo/ 

UCSB – University of 
California at Santa Barbara 

BioSens http://www.chemengr.uc
sb.edu/~ceweb/faculty/d
oyle/biosens/ 

UNC – University of North 
Carolina 

BioNets http://x.amath.unc.edu:1
6080/BioNetS/ 

UPENN – University of 
Pennsylvania  

Charon http://www.cis.upenn.ed
u/mobies/charon 

UTK-ORNL 
University of Tennessee and  
Oak Ridge National Labs 

BioGrid, BioSmokey, 
 BioSpreadsheet, ESS, 
OctaveBridge 

http://biocomp.ece.utk.e
du/ 

VaTech – Virginia Institute 
of Technology 

BioPak, JigCell http://jigcell.biol.vt.edu/ 

WRAIR – Walter Reed 
Army Institute of Research 

GeneCite, Pathway Screen  
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Appendix 2: Bio-SPICE Usability Testing 
 
 
 

Five models were used to test several Bio-SPICE tools, editors and 
simulators, in order to evaluate tool usability. The five models used were: 
 
 
• Circadian rhythm, mRNA transcription and protein phosphorylation  
 (Smolen P et al, J Neurosci, 21:6644-6656, 2001)  
  14 ODEs;  20 mass action reactions. 
 
• Circadian rhythm II, mRNA transcription and protein phosphorylation  

(same as Circadian rhythm scaled to 95 ODEs;  100 mass action 
reactions.) 

 
• Cell division cycle, cdc2 and cyclin interactions 
  (Tyson J, PNAS, 88:7328-7332, 1991)  

  6 ODEs;  14 reaction equations. 
 
• Allosteric model for glycolytic oscillations  
 (Goldbeter A & Lefever R, Biophys J, 12:1302-1315, 1972)  
   2 ODEs (minimal model) 
 
• Memory induction 
 (Pettigrew D et al, J Comp Neurosci, 18:163-181, 2005) 
   16 ODEs; 39 reaction equations. 

 
 
 
 
The simulators/editors were evaluated (when possible) with both a code specific 
implementation of the model using the editor tool and a SBML version which is 
suppose to be interoperable between simulators/editors.  The table below 
indicates which models were tested with the various simulators/editors. These 
models can be found at the web site: http://nba.uth.tmc.edu/darpa/
click menu MODEL CODE to find a copy of the table with links to the various 
models. Also, PDF documents of posters presented at DARPA Bio-SPICE 
conferences can be found in the Document page (click menu DOCUMENTS) as 
well as the Getting Started manual and Jarnac Use Case document. 
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 Circadian 

Rhythm I 
Circadian 
Rhythm II 

Cell Division 
Cycle 

Allosteric 
Glycolytic 
Oscillations 

Memory 
Induction 

 code 
specific 

SBML code 
specific 

SBML code 
specific 

SBML code 
specific 

SBML code 
specific 

SBML 

BioSpreadSheet/ 
ESS 

CR CR CR100  CDC      

BioSketchPad/ 
Charon 

CR    CDC      

Jarnac/ 
JDesigner 

CR CR CR100  CDC CDC AGO  MI  

JigCell CR CR CR100  CDC CDC AGO  MI MI 

Simpathica CR CR CR100 CR100 CDC CDC     

BioNets CR  CR100  CDC      

PathwayBuilder CR CR   CDC  CDC     
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